登録日
2017年8月8日

メンバー検索

  

mikazukikan

名前(ニックネーム)
三日月
自分のconcrete5サイト
ホームページ
自己紹介
超初心者です。concrete5が大好きで勉強中です。
concrete5.org のユーザー名
mikazukikan
concrete5 Slack Team ID
Twitterアカウント
フォーラム総投稿数
10

コミュニティバッジ

投稿

1から10までを表示 (計10)

Re: ロリポップのPHP7.3モジュール版でインストール可能でしょうか

結局モジュール版ではなくCGI版で、無事最新版をインストールすることができました。
ありがとうございました。

Posted on 7月 10, 2020 at 4:04 午前

掲示板機能はありますでしょうか

いつもこのフォーラムには助けて頂きありがとうござます。
掲示板機能をサイトに組み込みたいと思っています。

・トップページは全ての人が閲覧可能
・その下の4ページそれぞれに、会員のみが閲覧可能なページを作成したい
・その4つのページそれぞれに、会員が自由にスレッドを立てられる、コミュニケーションを取れる掲示板機能を付けたい

という感じで、サイト作成をしたいと思っています。
フォーラムの機能は、今はアドオンでも配布していないみたいですし、
過去のフォーラムのディスカッションで掲示板機能についてのものも全て拝見致しましたが、
どれも古いスレッドでしたので、改めて書き込みさして頂きました。

会員とコミュニケーションを取りやすい機能がどうしても必要です。
昔、サイト閲覧者と気軽にコミュニケーションを取る場として、CGIで掲示板を設置していましたが、そんな感じで気軽にコミュニケーションを取る場をconcrete5で作ることは可能でしょうか。

コメントブロックを使って、フォーラムみたいにできないか、、とかも考えたのですが・・・

concrete5 のバージョンは、 8.2.1 です。

ご教授頂けましたら幸いです。
どうぞ宜しくお願い致します。

Posted on 7月 09, 2020 at 2:41 午後

Re: ロリポップのPHP7.3モジュール版でインストール可能でしょうか

ご返信ありがとうございます!

どうせインストールするなら最新版を、と8.5.4を直接インストールしようとしましたがうまくいかなかったので、
5.6.4.0jaをまずはインストールして、管理画面でアップデートをしようとしました。
でも、データベースを空にしてインストールをしようとしても、
下記のエラーが出て、先へ進めません。
ーーー
Warning: Use of undefined constant LANGUAGE - assumed 'LANGUAGE' (this will throw an Error in a future version of PHP) in /home/users/0/main.jp-marumika/web/public/concrete/helpers/text.php on line 16

Warning: Use of undefined constant LANGUAGE - assumed 'LANGUAGE' (this will throw an Error in a future version of PHP) in /home/users/0/main.jp-marumika/web/public/concrete/helpers/text.php on line 16
{"error":false}
ーーー
最初に8.5.4をインストールしようとしたので、このようなエラーが出るのだと思い、
データベースを一度削除し、新たにデータベースを作成、その後インストールしようとしても、
インストール画面が表示されると同時に勝手にインストールが始まり、上記のエラーが出ます。

テストサイトで、エクストリムでconcrete5の簡単インストールをし、その後、アップデートを繰り返し、
8.2.1までアップデート出来ました。

ロリポップで一年契約したところなので、出来るだけconcrete5を設置したいと思っていますが、
うまくいかないなら、エクストリムでやっていこうかな、と考え中です。

ご助言頂ければ幸いです。
どうぞよろしくお願い致します。

Posted on 7月 04, 2020 at 10:38 午前

Re: ロリポップのPHP7.3モジュール版でインストール可能でしょうか

concrete5.6.4.0jaをインストールして、管理画面でアップグレードをしていくことにしました。
ありがとうございました。

Posted on 7月 01, 2020 at 1:19 午後

ロリポップのPHP7.3モジュール版でインストール可能でしょうか

3年ほど前、ロリポップのライトプラン、PHP7.1CGI版で
cocncrete5でHPを作成したのですが、HPの表示が遅いので不満がありました。
この度別のHPを作成するに当たり、
ロリポップ スタンダードプラン PHP7.3モジュール版で
concrete5をインストールしようとしてみましたが、うまくいきません。
言語設定画面は出るのですが、レイアウトが崩れており、一応日本語を設定できて
次の画面へいくと、その先へはいけなくなってしまいます。
モジュール版は、実行プロセスがApacheのプロセスで、レスポンスは高速となっていますが、
CGI版でないと作動しないのでしょうか。
また、モジュール版では、PHP iniの設定変更が出来ず、セーフモードオフなどの確認、変更が出来ません。
CGI版は7.1〜7.4に設定できます。

インストールが進まず困っています。
どうぞよろしくお願い致します。

利用しているconcrete5のバージョン→8.5.4
利用しているブラウザ→Opera、Google Chrome、Safari
concrete5が動いている環境
→ レンタルサーバならサーバの会社とプラン→ロリポップのスタンダードプラン
→ PHPやMySQLなどのバージョン(わかれば)→Server type: MySQL
サーバのバージョン: 5.6.23-log - MySQL Community Server (GPL)
PC環境→macOS Catalina バージョン10.15.5

Posted on 6月 30, 2020 at 2:48 午前

Re: 独自ドメインに切り替えたら、ファイルが表示されずレイアウトも崩れている

nipper様

いつもありがとうございます!

独自ドメインの方の管理画面で、キャッシュクリアをしたら、
表示されるようになりました!
ロリポップのドメインでの管理画面ではキャッシュクリアをしていたのですが、
独自ドメインの管理画面ではしていませんでした。
勉強になりました。

いつも本当にありがとうございます。
今後ともどうぞよろしくお願い致します。

Posted on 8月 22, 2017 at 11:54 午前

独自ドメインに切り替えたら、ファイルが表示されずレイアウトも崩れている

いつもお世話になっております。
どうぞよろしくお願い致します。

ミニムというサーバーに独自ドメインで置いていたHPを、
ロリポップに新たにconcrete5をインストールし、作り直ししました。
独自ドメインを取得したのはムームードメインで、
ミニムのHPで使っていたのですが、
そちらでの独自ドメインの設定を解除し、
ロリポップで独自ドメインを利用するように設定を致しました。
(ロリポップ様やムームードメイン様でも設定を確認して頂いております)

ロリポップのドメインでconcrete5をインストールし、HPを構築していたのですが、
独自ドメインに切り替えをしたら、
ファイルが全て表示されなくなり、レイアウトも崩れています。
管理画面のレイアウトもおかしくなっています。
管理画面のシステムと設定の、サーバー設定の環境情報も、読み込まれません。

ロリポップのドメインでは、綺麗に表示されています。
ロリポップのドメイン
http://mikazukikan.moo.jp/web/
独自ドメイン
http://mikazukikan.website/index.php

問題が解決したら、独自ドメインでプリティーURLに設定しようと思っています。

• 利用しているconcrete5のバージョン→8.2.1
• 利用しているブラウザ→Safari、Google Chrome、Opera
• concrete5が動いている環境
◦ → ロリポップ!のライトプラン
◦ →  PHP Version 7.1.5、MySQLのバージョン 5.6
 ・使っているテーマ:パレット

どうすれば独自ドメインでの表示が問題なくできるようになりますでしょうか。
初歩的な質問で申し訳ございませんが、どうぞよろしくお願い致します。

Posted on 8月 22, 2017 at 1:23 午前

Re: Re: テーマPaletteでSimple Blog setupが使えない

nipper様、ありがとうございます!
無事HW Simple Blogをインストールでき、ブログのページが設定できました。

そして、このページタイプでブログのページが出来るのは、勉強不足で知りませんでした。
ありがとうございます、今後自分でもこのページからいろんなページが作れるようになりたいです。

本当にありがとうございました!!

Posted on 8月 08, 2017 at 5:10 午後

Re: Re: テーマPaletteでSimple Blog setupが使えない

nipper様

すみません、そうです、「HW Simple Blog」です!
うまく設置ができません・・・
よろしくお願い致します。

Posted on 8月 08, 2017 at 3:29 午後

テーマPaletteでSimple Blog setupが使えない

超初心者ですが、concrete5が大好きで勉強中です。どうぞよろしくお願い致します。

・サーバー→ロリポップ ライトプラン(データベースが一つ使えます)
・MacBook Air Mac OS Sierra(バージョン10.12.6)
・concrete5 バージョン8.2.1(最新版)

最初、上記内容でconcrete5を問題なくダウンロードでき、テーマをパレットに切り替えることができたのですが、別のサーバーでconcrete5バージョン5.7.5.13、テーマPaletteで使っていたアドオンSimple Blog setupをインストールしようとしたところ、

An unexpected error occurred.
Call to undefined method Concrete\Core\Entity\Attribute\Key\PageKey::delete()

というエラーが出て、インストールできませんでした。

サイトにブログを付けたいので、データベースを空にし、5.7.5.13を再インストールしようとしたところ、エラーが出てインストールできなかったので、調べましたところ、PHP7.1の場合、5.7.5.13はインストールできない事例があるようで、全く同じ症状でしたので、改めてデータベースを空にし、8.2.1をインストールし直しました。

今、インストールしたconcrete5は正常に動いているのですが、やっぱりアドオンSimple Blog setupが使えません。まだ8.2.1に対応できていないんだとは思いますが、以前使えていただけに、使いたい気持ちが強いです。他に有料のblogのアドオンもあるようですが・・・

ブログのページをPaletteに作る方法は他にありますでしょうか?

どうぞよろしくお願い致します。

Posted on 8月 08, 2017 at 1:24 午後