ロリポップのPHP7.3モジュール版でインストール可能でしょうか

2020年6月30日 at 2:48

3年ほど前、ロリポップのライトプラン、PHP7.1CGI版で
cocncrete5でHPを作成したのですが、HPの表示が遅いので不満がありました。
この度別のHPを作成するに当たり、
ロリポップ スタンダードプラン PHP7.3モジュール版で
concrete5をインストールしようとしてみましたが、うまくいきません。
言語設定画面は出るのですが、レイアウトが崩れており、一応日本語を設定できて
次の画面へいくと、その先へはいけなくなってしまいます。
モジュール版は、実行プロセスがApacheのプロセスで、レスポンスは高速となっていますが、
CGI版でないと作動しないのでしょうか。
また、モジュール版では、PHP iniの設定変更が出来ず、セーフモードオフなどの確認、変更が出来ません。
CGI版は7.1〜7.4に設定できます。

インストールが進まず困っています。
どうぞよろしくお願い致します。

利用しているconcrete5のバージョン→8.5.4
利用しているブラウザ→Opera、Google Chrome、Safari
concrete5が動いている環境
→ レンタルサーバならサーバの会社とプラン→ロリポップのスタンダードプラン
→ PHPやMySQLなどのバージョン(わかれば)→Server type: MySQL
サーバのバージョン: 5.6.23-log - MySQL Community Server (GPL)
PC環境→macOS Catalina バージョン10.15.5

タグ:

Re: ロリポップのPHP7.3モジュール版でインストール可能でしょうか

2020年7月1日 at 13:19
concrete5.6.4.0jaをインストールして、管理画面でアップグレードをしていくことにしました。
ありがとうございました。
 

Re: ロリポップのPHP7.3モジュール版でインストール可能でしょうか

2020年7月1日 at 13:44
> concrete5.6.4.0jaをインストールして、

すみません。

8.5.4 を利用希望で、
5.6.4.0ja にアップデートということだったので念の為に確認しますが、

今のバージョンは 5.6.4.0.ja 未満でサイトを作っているということでしょうか?

それであれば、5.6.4.0.ja であれば、僕は PHP7.2 まで動作確認いたしました。
 

Re: ロリポップのPHP7.3モジュール版でインストール可能でしょうか

2020年7月4日 at 10:38
ご返信ありがとうございます!

どうせインストールするなら最新版を、と8.5.4を直接インストールしようとしましたがうまくいかなかったので、
5.6.4.0jaをまずはインストールして、管理画面でアップデートをしようとしました。
でも、データベースを空にしてインストールをしようとしても、
下記のエラーが出て、先へ進めません。
ーーー
Warning: Use of undefined constant LANGUAGE - assumed 'LANGUAGE' (this will throw an Error in a future version of PHP) in /home/users/0/main.jp-marumika/web/public/concrete/helpers/text.php on line 16

Warning: Use of undefined constant LANGUAGE - assumed 'LANGUAGE' (this will throw an Error in a future version of PHP) in /home/users/0/main.jp-marumika/web/public/concrete/helpers/text.php on line 16
{"error":false}
ーーー
最初に8.5.4をインストールしようとしたので、このようなエラーが出るのだと思い、
データベースを一度削除し、新たにデータベースを作成、その後インストールしようとしても、
インストール画面が表示されると同時に勝手にインストールが始まり、上記のエラーが出ます。

テストサイトで、エクストリムでconcrete5の簡単インストールをし、その後、アップデートを繰り返し、
8.2.1までアップデート出来ました。

ロリポップで一年契約したところなので、出来るだけconcrete5を設置したいと思っていますが、
うまくいかないなら、エクストリムでやっていこうかな、と考え中です。

ご助言頂ければ幸いです。
どうぞよろしくお願い致します。