登録日
2012年2月22日

メンバー検索

  

momo

名前(ニックネーム)
モモ
自分のconcrete5サイト
ホームページ
自己紹介
concrete5.org のユーザー名
concrete5 Slack Team ID
Twitterアカウント
フォーラム総投稿数
223

コミュニティバッジ

投稿

1から10までを表示 (計221)

Re: エラー Unclosed string at position:

「Event Calendar」をアンインストールしたら正常に表示されるようになりました。
wordpressのようにconcrete5のアドオンを一時停止できたらいいと思いますが・・。

Posted on 3月 12, 2020 at 8:52 午後

予期せぬエラーが発生しました。「Class Concrete\Core\Permission\Key\CalendarAdminKey does not exist」

他に質問しましたが、アップデートが上手くいかず、いくつかのバージョンで試しながら試行錯誤していたら下記のエラー表示が出るようになりました。

---
予期せぬエラーが発生しました。
「Class Concrete\Core\Permission\Key\CalendarAdminKey does not exist」が表示される
---

編集ができるようにするにはどのように対処したらよろしいでしょうか?
お手数をおかけいたしますが、何卒ご教示のほど、よろしくお願い申し上げます。

【概要】
・バージョン :8.2.1
・テーマ   :palette
・サーバー  :さくらインターネット スタンダード
・PHP     :5.6.40(7.3にアップすると真っ白になる)

Posted on 3月 12, 2020 at 7:37 午後

エラー Unclosed string at position:

バージョンを8.5.2へアップデートしたら、下記のエラーが出ました。

RuntimeException
Unclosed string at position: 69780

環境状況は以下です
----------------------------------------------------------------------------------------------------------------------------------------
# concrete5 Version
Core Version - 8.5.2
Version Installed - 8.5.2
Database Version - 20190925072210

# Database Information
Version: 5.5.59-log
SQL Mode:

# concrete5 Packages
ABC Auto Reply forms (1.0.4), Dynamic Images (1.1), Editor Comment (7.0.1), Event Calendar (3.4), Palette (2.0.4), Spacer (0.9.3)

# concrete5 Overrides
None

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Apache

# Server API
cgi-fcgi

# PHP Version
7.3.14

# PHP Extensions
apcu, cgi-fcgi, Core, ctype, curl, date, dom, exif, fileinfo, filter, gd, gettext, gmp, hash, iconv, intl, json, libxml, mbstring, mcrypt, mysqli, mysqlnd, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, Reflection, session, SimpleXML, snmp, soap, SPL, sqlite3, standard, tokenizer, xml, xmlreader, xmlwriter, xsl, Zend OPcache, zip, zlib

# PHP Settings
max_execution_time - 30
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - -1
max_input_vars - 1000
memory_limit - 128M
post_max_size - 8M
upload_max_filesize - 2M
mbstring.regex_stack_limit - 100000
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - no value
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
opcache.max_accelerated_files - 10000
opcache.max_file_size - 0
opcache.max_wasted_percentage - 5
----------------------------------------------------------------------------------------------------------------------------------------
サーバーはさくらインターネット

ログの内容は以下です
Exception Occurred: /home/kinta13/www/astcom/updates/concrete5-8.5.2/concrete/vendor/tedivm/jshrink/src/JShrink/Minifier.php:479 Unclosed string at position: 69780 (0)


ログイン画面と管理画面は正常に表示され、管理画面のメニューは正常に動作します。

修正方法をご教示ください
よろしくお願いいたします。

Posted on 3月 10, 2020 at 4:52 午後

Re: C5DK TwentyTwenty Imageの不具合について

ありがとうございます。

38行目のregisterViewAssetsその中に
$this->requireAsset('javascript', 'c5dktwentytwenty');
を追加しても症状は変わらず、

下記を別途、丸々追記すると
public function registerViewAssets($outputContent = '') {
$this->requireAsset('javascript', 'c5dktwentytwenty');
}

下記のエラーが表示されます。
Cannot redeclare Concrete\Package\C5dkTwentytwentyImage\Block\C5dkTwentytwentyImage\Controller::registerViewAssets()

Posted on 11月 15, 2019 at 10:08 午前

エラー表示 Call to a member function getThumbnailURL() on null

Easy Image Sliderのアドオンを使用中下記のエラーが表示されました。
改善方法をご教示ください。

『Call to a member function getThumbnailURL() on null』

C5:8.5.2
PHP:7.3.9
サーバー:さくらインターネット スタンダード

サーバーのエラーロゴより
[Thu Nov 14 09:54:20.376780 2019] [cgi:error] [pid 51188] [client 60.106.137.236:0] End of script output before headers: index.php, referer:http://garcon-trust.jp/index.php?cID=381&ctask=check-out-first&ccm_token=1573690104:cfc8ca6b9ccd99b338ceb9fc2201504f

以上、何卒宜しくお願い致します。

Posted on 11月 14, 2019 at 11:19 午前

Re: C5DK TwentyTwenty Imageの不具合について

ありがとうございます。

参考ページを参照してやってみたのですが、うまくいきませんでした。
アセットの登録が間違っているのかも知れません。

どのJSが読み込めていないかは判明はしました。
フッターに読み込むべき記述がされていても読み込んでいないと言うことがあるということでしょうか?

application/bootstrap/app.phpに下記を記述しました。
-------------------------------------------------------------------------------------------------------------------------------------------
$al->register(
'javascript', 'c5dktwentytwenty', 'packages/c5dk_twentytwenty_image/js/jquery.twentytwenty.js'
);
-------------------------------------------------------------------------------------------------------------------------------------------
どのファイルに指定の文字列を追記していいのかわからないところがあります。

また、/packages/c5dk_twentytwenty_image/blocks/c5dk_twentytwenty_image/controller.phpに下記を記述しました。
-------------------------------------------------------------------------------------------------------------------------------------------
public function registerViewAssets($outputContent = '') {
$this->requireAsset('javascript', 'c5dktwentytwenty');
}
-------------------------------------------------------------------------------------------------------------------------------------------
上記を記述するとエラーメッセージが表示されます。
-------------------------------------------------------------------------------------------------------------------------------------------
Cannot redeclare Concrete\Package\C5dkTwentytwentyImage\Block\C5dkTwentytwentyImage\Controller::registerViewAssets()
-------------------------------------------------------------------------------------------------------------------------------------------
間違っている箇所があればご指摘ください。

下記をヘッダーに追記したら正常に表示されました。
<script type="text/javascript" src="/packages/c5dk_twentytwenty_image/js/jquery.twentytwenty.js"></script>

Posted on 11月 12, 2019 at 6:22 午後

Re: Easy Images SliderのPHPエラーについて

ありがとうございます。
ご教示通り編集をしましたところ、PHPのバージョンを上げても正常に表示されるようになりました。

Posted on 11月 06, 2019 at 3:08 午後

Re: C5DK TwentyTwenty Imageの不具合について

ありがとうございます。
registerViewAssetsの具体的な対応方法をご教示いただけますでしょうか。
宜しくお願い致します。

Posted on 11月 06, 2019 at 3:05 午後

C5DK TwentyTwenty Imageの不具合について

C5を8.5.2にアップしたら、添付画像のようにログイン状態では正常な表示がされるのに、ログアウト後、通常の表示にしたら画像が上下に表示されるようになりました。

ログイン状態のような正常に表示させる方法がありましたら、ご教示ください。

Posted on 11月 04, 2019 at 2:36 午後

Easy Images SliderのPHPエラーについて

サイト内でEasy Images Sliderのアドオンを使用していますが、PHPのバージョンを7.3に揚げると下記のエラーメッセージが出ます。

------------------------------------------------------------------------------------------------------------------------------
Declaration of Concrete\Package\EasyImageSlider\Block\EasyImageSlider\Controller::registerViewAssets() should be compatible with Concrete\Core\Block\BlockController::registerViewAssets($outputContent = '')
------------------------------------------------------------------------------------------------------------------------------
直訳するとコアブロックとの互換性がないとのことですが、修正方法はありますでしょうか?
PHP5.6にすると正常に表示されますが、7.2でも同様にエラーになります。

レンタルサーバー会社とコースは、さくらインターネット スタンダードです。

Posted on 11月 04, 2019 at 11:59 午前
« 前1234567...23次 »