登録日
2012年8月25日

メンバー検索

  

yasugen

名前(ニックネーム)
yasu
自分のconcrete5サイト
ホームページ
自己紹介
concrete5.org のユーザー名
concrete5 Slack Team ID
Twitterアカウント
フォーラム総投稿数
87

コミュニティバッジ

投稿

11から20までを表示 (計87)

8.5.1にアップグレードしたら記事ブロックが編集できなくなった

いつもお世話になっております。

さくらインターネットで運用しているサイトがあるのですが、phpのバージョンが7.3になるとのことで現状の7.2からアップしてテストをしています。

先だって別の投稿でKatzさんからphp7.3に対応したconcrete5のバージョンは8.5.1であると教えて頂き、現行の8.3.2からアップしました。

ページは出ますし問題なく動いているようなのですが、
記事ブロックの編集パネル(編集ボタン群のパネル?)が表示されなくなっています。
またコンポーザの画面ではトピックツリーが表示されず、やはり記事ブロックが表示されていません。

試しにstuccoテーマをデフォルトのエレメンタルに切り替えてみたところいずれも正常に操作できます。

画面にエラーなどは出ていません。
どうすればよいのか、何を調べればよいのか分からず困っています。

よろしくおねがいします。



# concrete5 Version
Core Version - 8.5.1
Version Installed - 8.5.1
Database Version - 20190301133300

# concrete5 Packages
Easy Image Gallery (1.4.2), Stucco (2.1.6)

# concrete5 Overrides
None

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/7.3.6

# Server API
apache2handler

# PHP Version
7.3.6

# PHP Extensions
apache2handler, bcmath, bz2, calendar, Core, ctype, date, dom, fileinfo, filter, gd, hash, iconv, json, libxml, mbstring, mysqli, mysqlnd, pcre, PDO, pdo_mysql, Phar, readline, Reflection, session, SimpleXML, SPL, standard, tokenizer, wddx, xml, xmlreader, xmlwriter, zip, zlib

# PHP Settings
max_execution_time - 180
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 10000
memory_limit - 1024M
post_max_size - 80M
upload_max_filesize - 128M
mbstring.regex_stack_limit - 100000
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - no value
session.gc_maxlifetime - 7200

Posted on 6月 22, 2019 at 9:24 午前

Re: テーマのバージョンアップ方法を教えて下さい

自己解決しました(と思います)。

テーマの最新版をダウンロードしてpackagesフォルダの中の既存のフォルダ(theme_stucco)を上書きし、管理画面の「concrete5を拡張」の「機能追加」でインストールする。

以上の手順でstucco2.1.4を2.1.6へアップグレードできました。


ただ、concrete5 8.5.1でstucco2.1.4でも2.1.6でも記事ブロックの編集で、編集パネル(なんていうのかわかりませんが編集のボタン群)が表示されません。
デフォルトのテーマのエレメンタルに切り替えると普通に動きます。
改めて別の投稿で質問しようと思います。

Posted on 6月 22, 2019 at 9:01 午前

テーマのバージョンアップ方法を教えて下さい

いつもお世話になっております。

とても初歩的なことなのかもしれませんがテーマのバージョンアップの仕方がわからず質問させてください。

現在8.3.2、stucco2.1.4を使っています。
さくらインターネットのホスティングで運用していますが、phpバージョンを7.2から7.3に上げると通知がきたもので対応をしなければならない状況です。

まずphp7.3に対応するconcrete5のバージョンは8.5.1とのことでしたので、開発環境(xampp)でテストのため新規インストールをしました。
次いでstucco2.1.4をインストールしたところ、インストール前には出来ていた記事ブロックなどの編集ができなくなっていました。

対処としてstuccoの最新バージョン2.1.6にアップデートして試そうと思ったのですが、アップデートの仕方がわかりません。
あれこれ検索したのですが探し方が悪いのか見つかりません。

初歩的な質問ですみませんが、テーマのアップデートの方法を教えて頂けますでしょうか?
よろしくお願いいたします。

Posted on 6月 21, 2019 at 1:17 午後

Re: 8.3.2でphpバージョンを7.2.15から7.3.6にアップしたら

いつもありがとうございます。

php7.3に対応は8.5.1からなのですね。

実は8.4.4にアップした際にmysqlの設定のonly_full_group_by をoffにしないとスタックの登録でエラーになってしまって8.3.1に戻した経緯があります。
さくらインターネットの環境ではonly_full_group_by をoffにできなかったからです。

今回8.5.1にアップして同じ問題になった場合はやはり8.3.2に戻さなければならず・・・

開発環境で試してみることにします。
ありがとうございます。

Posted on 6月 19, 2019 at 2:26 午後

8.3.2でphpバージョンを7.2.15から7.3.6にアップしたら

いつもお世話になっております。

さくらインターネットのホストのphpバージョンが7.2から7.3に上がると通知があり、concrete5 8.3.2環境でテストをしました。
テスト環境はXAMPPです。

いくつかソースを編集する箇所がありましたが動作はするようにできました。
ところが環境情報の表示で「環境情報を読み込めません」となったまま表示されなくなりました。
確認のためphpを7.2.15に戻したところ正常に表示されます。

原因はなんでしょうか?

一通りの動作は問題なさそうですが思わぬところで不具合が出るような気もします。

よろしくお願いいたします。

Posted on 6月 18, 2019 at 5:55 午後

php7.3対応のバージョンは?

いつもお世話になっております。

現状8.3.2を使っています。

サーバはさくらインターネットで、先だってphpバージョンを7.2から7.3へアップすると通知が来ました。

concrete5としてphp7.3に対応するバージョンはいくつになるのでしょうか?

Posted on 6月 18, 2019 at 2:22 午後

Re: 8.3.1から8.4.4へアップデートしましたが元に戻す方法はありますか?

有難うございます。
やはりアップデート前のデータベースが必要ですよね。

今回アップデートして相当の手を加えておりまして、終盤にドキュメントライブラリを追加したところでエラーになってしまって、そこまでの編集を全て無くしてダウングレードするとなると新規に8.3.2を入れてそこで構築し直したほうがスッキリする気がしてます。

せっかくご教授頂いたのに本当に申し訳ありませんが、最後の最後でエラーになりショックが大きく、かつ手戻りが大きすぎて・・・もう少し気持ちが落ち着いてから考えます。

有難うございます。

Posted on 3月 27, 2019 at 7:40 午後

Re: Re: 8.3.1から8.4.4へアップデートしましたが元に戻す方法はありますか?

ご返事ありがとうございます。

手順は「手動で管理画面からアップデートする」だったはずですが、もしかすると「リモートアップデート」だったかもしれません。

よろしくお願いいたします。

Posted on 3月 27, 2019 at 10:14 午前

Re: 8.3.1から8.4.4へアップデートしましたが元に戻す方法はありますか?

ご返事有難うございます。

ドキュメントライブラリの件ですが、標準のブロックで起きています。
エアーは内容は以下の通りで、海外の投稿ではMysqlの設定変更で対処するとあるのですが、さくらのサーバーでは変更できないとの回答とさくらからもらっています。

(海外の投稿)
http://github.com/concrete5/concrete5/issues/7311

(エラー内容)
An exception occurred while executing 'SELECT distinct n.treeNodeID, if(nt.treeNodeTypeHandle='file', fv.fvTitle, n.treeNodeName) as folderItemName, if(nt.treeNodeTypeHandle='file', fv.fvDateAdded, n.dateModified) as folderItemModified, case when nt.treeNodeTypeHandle='search_preset' then 1 when nt.treeNodeTypeHandle='file_folder' then 2 else (10 + fvType) end as folderItemType, fv.fvSize as folderItemSize FROM TreeNodes n INNER JOIN TreeNodeTypes nt ON nt.treeNodeTypeID = n.treeNodeTypeID LEFT JOIN TreeFileNodes tf ON tf.treeNodeID = n.treeNodeID LEFT JOIN FileVersions fv ON tf.fID = fv.fID and fv.fvIsApproved = 1 LEFT JOIN FileSetFiles fsf ON tf.fID = fsf.fID LEFT JOIN FileSearchIndexAttributes fis ON fv.fID = fis.fID WHERE ((nt.treeNodeTypeHandle = "file_folder") OR (fsf.fsID = 1)) AND (n.treeNodeParentID = ?) ORDER BY fv.fvTitle asc LIMIT 20 OFFSET 0' with params ["7"]: SQLSTATE[HY000]: General error: 3065 Expression #1 of ORDER BY clause is not in SELECT list, references column 'k2-infinities_k2i_data.fv.fvTitle' which is not in SELECT list; this is incompatible with DISTINCT

(サーバ環境)
# concrete5 Version
Core Version - 8.4.5
Version Installed - 8.4.5
Database Version - 20180717000000

# concrete5 Packages
Stucco (2.1.6)

# concrete5 Overrides
None

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Apache

# Server API
apache2handler

# PHP Version
7.2.14

# PHP Extensions
apache2handler, apcu, Core, ctype, curl, date, dom, exif, fileinfo, filter, gd, gettext, gmp, hash, iconv, intl, json, libxml, mbstring, mcrypt, mysqli, mysqlnd, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, Reflection, session, SimpleXML, snmp, soap, SPL, sqlite3, standard, tokenizer, xml, xmlreader, xmlwriter, xsl, Zend OPcache, zip, zlib

# PHP Settings
max_execution_time - 30
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - -1
max_input_vars - 1000
memory_limit - 128M
post_max_size - 8M
upload_max_filesize - 2M
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
opcache.max_accelerated_files - 10000
opcache.max_file_size - 0
opcache.max_wasted_percentage - 5

Posted on 3月 27, 2019 at 10:12 午前

8.3.1から8.4.4へアップデートしましたが元に戻す方法はありますか?

8.3.1から8.4.4へアップデートしましたが、ドキュメントライブラリがエラーで使えずバージョンダウンさせようかと考えたのですが方法がわかりません。
(検索してみたのですが該当するものが見つけられませんでした)

環境はさくらのレンタルサーバです。

よろしくお願いいたします。

Posted on 3月 22, 2019 at 8:40 午後